Archived

This topic is now archived and is closed to further replies.

Zoiks

Windows 10 Updates Killed my AOE II

Recommended Posts

I could use some help getting my AOE working again.  I've always had WINDOWS 10 and AOE II HD worked fine through STEAM.  WINDOWS 10 forced it's upgrades for the 50th, and the next two updates.  So my WINDOWS 10 has been updated as of Oct 1 and is completely current.  AOE II now won't launch correctly after these WINDOWS UPDATES.   I can go into STEAM.  Click on the AOE II HD icon and it will jump to the first screen as the music plays.  When it transitions to the main screen that shows multi-player, single player, options etc...all sound stops.  3/4 of the time it will kick me out of this screen and send me back to STEAM.  1/4 of the time I can pick single player and it will start the game with no sound.  Then anywhere from 10 seconds to 3-4 minutes it will kick me out and send me back to STEAM.  So, I have not access to AOE II HD at this time.

 

Any help on how to fix this?  I've uninstalled STEAM and AOE II HD and that has made no difference.  Thanks for the help.

Share this post


Link to post
Share on other sites

Same here.  Honestly, I do not understand how or why this is so *** difficult to get a game to work on Windows 10.  You have such a MASSIVE fan-base spanning the globe, but yet you have not created a patch that will allow this game to work on Win10.   This is one of my ALL TIME favorite games as is for a lot of other people out there.  A little love our way would be appreciated.

Share this post


Link to post
Share on other sites

Having the same problem!  I thought it was because my graphics driver was not up to date, and I upgraded my driver, and I met many more problems.  Finally I was able to roll back my graphics, and now I find out it is Window 10 to blame for!  Is it that difficult to make two products of one company live harmoniously with each other?

Just now, running wolf said:

Having the same problem!  I thought it was because my graphics driver was not up to date, and I upgraded my driver, and I met many more problems.  Finally I was able to roll back my graphics, and now I find out it is Window 10 to blame for!  Is it that difficult to make two products of one company live harmoniously with each other?

And I wrote to support, but received no reply for 2 weeks.  Then I started a discussion on Steam, and got nothing, either.

Share this post


Link to post
Share on other sites

Let me know what supports says.  I still have unanswered requests for help.  Just to be clear, my laptop came with Windows 10 installed and AOE HD worked fine until the updates to Windows 10 happened in the last 2-3 weeks ago.  Those updates to my existing Windows 10 is what has killed my access to AOE HD.   Very disappointing!

Share this post


Link to post
Share on other sites

I have had similar problem.  Does someone know how to email support directly or is it all through these forums?  I am so frustrated with it because 4 times now it has crashed while I'm in battle, 3 of the 4 times counting it as a loss and taking crowns away from me.  I'm trying to collect pennants to unlock another hero and can't get anywhere with getting kicked out like this, not to mention the waste of resources and time.

Share this post


Link to post
Share on other sites

I have kinda the same problem, but for me, I can't even launch the game, when I double click on the icon or when I launch it through steam, it says game launched and few seconds later it says ready to be launched and nothing happens. If someone knows how to fix this problem, just let me know. PS: I just bought the hd version with african and forgoten dlcs.

Share this post


Link to post
Share on other sites

What is your current version of Windows 10 Zoiks BiggySiggy flyingeagle Farghost dave.pringle ? Do you mean that you have recently made a major update toward a higher version? Or, is it a normal updtate within your current windows version that lead to that?

https://support.microsoft.com/fr-fr/help/12387/windows-10-update-history

On 22/10/2016 at 2:44 AM, ObtainedLamb said:

I have had similar problem.  Does someone know how to email support directly or is it all through these forums?  I am so frustrated with it because 4 times now it has crashed while I'm in battle, 3 of the 4 times counting it as a loss and taking crowns away from me.  I'm trying to collect pennants to unlock another hero and can't get anywhere with getting kicked out like this, not to mention the waste of resources and time.

I don't think you're in the right forum section here, they are discussing AOE II, not AOE CS.

This were you should find what you are looking for :

https://forums.ageofempires.com/forum/60-aoe-cs-support/

Share this post


Link to post
Share on other sites

Well actually I just bought it and it doesnt work on my windows, and my Windows 10 is currently:

Edition: Windows 10 Family

Version: 1607

Operating system version: 14393.321

When i doubleclick the AOII icon, it show the little window with in it:"Launching preparation"(Im not really sure of the traduction, I'm french :D). In french it is said "Preparation du lancement de Age of Empires II:HD Edition"

 

Share this post


Link to post
Share on other sites

Ben pas sûr que se soit lié à Windows 10 dans ce cas, mais c'est pas impossible.

Il me semble que cette fenêtre peut durer un petit moment la première que tu lances un jeu avec Steam.

Moi j'arrive à y jouer avec un Eeebook X205TA et Windows 1511. J'ai ré-essayé ça marche encore même si c'est parfois long pour rejoindre une partie.

Si j'arrive à jouer sur une configuration digne d'une tablette d'entré de gamme, je pense que tout le monde devrait pouvoir y arriver.

Tu devrais peut-être ré-essayé, attendre 10 minutes, ou regarder dans la section support du jeu dans le forum de Steam.

"Bibliothèque" -> AOE II HD -> à droite : "Hub de la communauté" -> onglet : "Discussions" -> à droite sous "SOUS-FORUMS" sélectionnes : "Support" -> regardes le premier sujet épinglé : "Can't launch game FAQ"

Share this post


Link to post
Share on other sites

Ok merci, parceque j'ai le CD AOE II avec the conqueror expansion, mais il ne marche plus sur mon ordi,du coup je me suis dis que j'allais acheter un autre AOII mais depuis steam et puis il marche pas non plus donc je suis un peu deçu . Mais je vais regarder ça :) merci encore pour ta réponse,ça fait plaisir quand quelqu'un repond !!

Share this post


Link to post
Share on other sites

Here are more of the details of my problem.  My laptop started with Windows 10 so it was NOT one of the complaints of folks moving from Windows 7 or 8 and then upgrading to Windows 10.  I always had Windows 10.  Windows forced updates on 9/30/16, 10/11/16, 10/12/16, and 10/20/16.  I'm not clear which one of these updates killed my STEAM AOE HD but one of them killed it so it doesn't work.  The updates were KB3176935, ....6936....6937....Security update for Adobe flash player, KB3194798, KB3199209.  I think the issue was before 99209.  Here is the sequence:  1) In STEAM and click on PLAY, system progresses to the first colorful Age of Empires screen.  You have to click PLAY again at this screen.  2) The validation subscription screen comes up and you see the script.  I see the WTM_Finish sign.  You hear the music playing and then click on this screen to continue into the main game screen.  When I enter the main game screen where you can select options, single player, multiple player, etc...most of the time the music/sound disappears.  When this happens, the game is going to kick you out immediately or very shortly after entering the games.  If you hover in this view it looks fine.  Click on one of the icons and it will kick you out.  I've found that if you click too soon on the #2 screen it will kick you out immediately.  You have to wait for that to finish the subscription validation so you can hear the music and then click to get into #3.   Now, out of pure frustration I've clicked through this 10-20 times and I found that 1 out of 20 or 1 out of 30 attempts the game finally starts and I can play the game.  If I get to that final AOE HD screen for single player and multi-player and I can hear the music playing I know that I can play the game as used to.   So, come on Microsoft!  Let's help us out with a solution.  This is why every other computer I have is a Apple Macbook because Microsoft messes this up and then just leaves us hanging with no solution.  

If others have found a solution please let me know.  This is my favorite game and I can't play it since Microsoft FORCE THE UPDATES!

I should have mentioned...I'm only trying to play single player against the computer.  I've never played the multiplayer.  I enjoy playing me against 5-6 other computer opponents.  I did try to see if multi-player would work as part of my troubleshooting and I could not enter a game.  Folks said they could see my ping so they could not start the game with me in it.  Also, most of the time the game kicks out after clicking on the verifying subscription screen and never gets to that final screen.  Sometimes it gets to that final AOE screen and then kicks out as soon as you click on an icon for single player.  It always kicks you back into the main STEAM screen where you have to click PLAY again.

Share this post


Link to post
Share on other sites

  • Forum Statistics

    • Total Topics
      24236
    • Total Posts
      244599