Archived

This topic is now archived and is closed to further replies.

GarnetCrow

No sound in AoE2

Recommended Posts

Hello,

 I installed the AoE 2 from steam.When i enter AOE, there is no sound in games and menus (BGM, Sound effects...) I have already check my options, it's OK. 

But the start Movie has sound...  Thanks for your helps.

Share this post


Link to post
Share on other sites

I read looking for these files and then copy and paste them into the folder AGE2HD.  I tried finding who had written to do this and I could not find the same place...bottomline, this fixed my sound issue and the erratic launching of Steam Age of Empires.

 

Find these files and copy and paste them into the root folder AGE2HD (steam).  If fixed my lack of sound and intermittent launch. (WINDOWS 10):

 

D3DCompiler_43.dll

d3dcsx_43.dll

d3dx9_43.dll

dsound.dll   (I initially copied and pasted this and then I had sound that was messed up after a will.  I then removed this from the root directory and sound was find after that)

xactengine3_7.dll

XAPOFX1_5.dll

XAudio2_7.dll

 

I'm not a pro and I don't know what these files do but that is what the guy had suggested.  I was out of options when I tried it and now everything is fine on my MSI laptop with Windows 10.  It launched all the time but did not have sound.  When I copied and pasted these files I got sound that was fine but when the computer player would ask for resources the sound got all garble.  I took a guess at removing the dsound.dll from that root AGE2HD folder and that fixed the garbled sound problem.  I now have perfect sound too.   I have a new iBuypower PC and everything has worked fine on that PC from day 1.  It also has Windows 10.  Not sure why the MSI GE62 with Windows 10 had a problem. 

 

Good luck,

Share this post


Link to post
Share on other sites

  • Forum Statistics

    • Total Topics
      24236
    • Total Posts
      244599