Archived

This topic is now archived and is closed to further replies.

Doomedarchviledemon

Custom Scenario issue

Recommended Posts

I am currently experiencing troubles with trying to get my Custom Scenario to run the way that a standard map would. I have recently created a custom scenario and would like to play it with others via multiplayer but unfortunately when selecting a civilization we do not start with their bonuses, such as extra units, less resources, or extra resources. (The Chinese, for example, are suppose to start with three extra villagers but -200 food, but this is not the case when trying to play on the custom scenario) This is also an issue when trying to play in Single Player and even when trying to test the scenario within the Custom Scenario editor. There's simply no starting bonuses.

My initial thought was that after I created a scenario it would start up like any other normal map would, but is this not the case? Or is there something extra that I need to do on top of simply creating the map? I have included the scenario file below for reference. Any help would be very appreciated.

 

Scenario Download

Share this post


Link to post
Share on other sites

Hi,

This is because you selected All Techs in the scenario. When you have All Techs active, all civ bonuses are removed. So Civilisations do not mean anything in All Techs, except for their unique units. Not even unique techs can be researched. So all you have to do is just untick All Techs before playing, and it should work.

Hope this helps.

Share this post


Link to post
Share on other sites

Thank you for the quick reply. However, this has not solved my issue. The All Techs box is not selected in the Custom Scenario editor or in the Single Player/Multiplayer windows when starting the game. I have always left them unchecked but still do not get any of their bonuses. Unless there is a different option somewhere that I am not seeing or need to deselect/select I still do not know what I am doing wrong.

Additionally, I forgot to include this, while in Single Player the Number Of Players option is grayed out and I cannot select how many players I want in the game. Is there a way to make this adjustable again? (This can be seen in one of the attached screenshots.)

I have included two screenshots of the two All Tech boxes I am aware of and both are not selected before I start the game. Are these boxes the ones you are referring to or is there another one?

Screenshot 1

Screenshot 2

Share this post


Link to post
Share on other sites
2 hours ago, Doomedarchviledemon said:

Thank you for the quick reply. However, this has not solved my issue. The All Techs box is not selected in the Custom Scenario editor or in the Single Player/Multiplayer windows when starting the game. I have always left them unchecked but still do not get any of their bonuses. Unless there is a different option somewhere that I am not seeing or need to deselect/select I still do not know what I am doing wrong.

 

This, I suggest you to go head over to the Steam Community Support page, over there they might be able to help you, I hope.

2 hours ago, Doomedarchviledemon said:

Additionally, I forgot to include this, while in Single Player the Number Of Players option is grayed out and I cannot select how many players I want in the game. Is there a way to make this adjustable again? (This can be seen in one of the attached screenshots.)

 

When a scenario is made, it has set everything from the map of the scenario, all the way to the number of players. So to change the number of players, you must change it in the scenario itself (unless if there is another way which I don't know). If you are like me, you'll probably create seven different versions of the scenario, one for one other player, one for two other players, etc..

Share this post


Link to post
Share on other sites

  • Forum Statistics

    • Total Topics
      24236
    • Total Posts
      244599