Archived

This topic is now archived and is closed to further replies.

JDub75

Old Version to new

Recommended Posts

Hello everyone

I am not sure if I am in the right place but I am hoping someone can help.

I own the actual CD Rom of Age of Empires II The Age of Kings and have tried to install it onto my new PC that runs on Windows 10. My assumption is that there is definitely enough computing power so there must be upgrades/patches/applications that I need in order to make it work.

Hope this makes sense. 

Share this post


Link to post
Share on other sites

I'm not sure what you mean in this post, but I think you have not installed it yet, yes?

If you haven't, I think there should be no problem (except for that water turning brown and grass turning reddish and all that which is not a problem), I once installed it on a Windows 8.1 laptop. It's not Windows 10, I know, but I suppose it might work for Windows 10 as well. Please tell me if I am not talking about what you are talking about...

Share this post


Link to post
Share on other sites

I did have some problems with DirectDraw on the original AOK version, but all is fine after I ran it in compatibility settings. Apparently some forums said our graphics cards were too "new"

Share this post


Link to post
Share on other sites

Hmm, yeah. That usually happens in old-ish games. But in this case, to be honest, I am not sure how to fix it. Sorry, but we need someone who is an expert in this technical field. Maybe you want to try checking the Microsoft support thing? They may be able to help you with this problem.

Share this post


Link to post
Share on other sites

  • Forum Statistics

    • Total Topics
      24236
    • Total Posts
      244599