Archived

This topic is now archived and is closed to further replies.

Garmonbozia81

Welcome to our brand new website

Recommended Posts

I am so happy we finally have a sharp, uniform and cohesive Age of Empires website and forums! [thumbup]

There's a lot more the web team could add to the media section and features section for each game, but I feel that for someone browsing your website looking for an introduction to each game it fits the bill.

That being said the only thing I could find with needs some attention are the system requirements for each title.  Some do not match the store page listed minimum requirements.  Please see the screenshots below for comparisons between the store page minimum system requirements and the minimum system requirements shown on the new Age of Empires website.

Minimum System Requirements (Website vs. Store)

Age of Empires III is a special case because it is still available in physical copies.  I noticed a discrepancy between the system requirements for the physical copy of Age of Empires: Complete Collection and the Steam version of Age of Empires: Complete Collection, so I'm not entirely sure if that is intentional or not.  If only one set of minimum system requirements can be listed for Age of Empires III, I would think the Steam version would take precedence because physical media is becoming obsolete. 

Share this post


Link to post
Share on other sites

Friendly the new site, but when in another language?
And when new ads on game age of empires? AGE OF EMPIRE 4 RETURN OR AGE OF EMPIRE ONLINE.
I hope this new site will bring real ads for the community.

Share this post


Link to post
Share on other sites

Thank you, rhrmn. I will go over the differences pointed out to you and will make the necessary changes.
Update: We made some of the changes suggested by you. Please let me know if you notice anything else.

Share this post


Link to post
Share on other sites

Well, I don't see any other errors at the moment.  That leaves suggestions...

On the Age of Empires II HD webpage you could combine the Age of Empires II HD description with the Age of Empires: The Conquerors description and add The Forgotten Expansion and The African Kingdoms Expansion to the Expansions section.  In the media section you could add the Age of Empires II trailer, Age of Empires II HD announcement trailer, The Forgotten Expansion trailer (may need to edit this trailer) and The African Kingdoms teaser trailer

On the Age of Empires III webpage media section you could add the The Warchiefs trailer and The Asian Dynasties trailer.  There are a lot more screenshots and wallpapers in the fan site kits for all three releases which could also be added to the media section.

On the Age of Mythology webpage game description you could mention that the Age of Mythology: Extended Edition includes the Titans Expansion and the Golden Gift campaign.  When the new expansion comes out for the Extended Edition, that could be added to an Expansions section on the webpage, similar to the Age of Empires II HD webpage.

 

Share this post


Link to post
Share on other sites

At the bottom of the main page there is the "Age of Empires Forum" paragraph (see picture). There is a "Join Our Community" button. When you click it, you are redirected to the main page again.

Link goes to: www.ageofempires.com

Link should go to: forums.ageofempires.com

CNS9PNQ.jpg

Something else, this is for the forum: at the bottom of the forum pages there is the Microsoft Studios logo. On the PC the proportions of the logo are wrong, stretched in height. This is OK using the phone. Also the logo is OK on the main page on PC. You know, logo Guidelines and so on ... 

Top shows forum, bottom shows main page.

UmqFSKK.jpg

 

 

Share this post


Link to post
Share on other sites

Garmon,

Will Disqus be coming soon to the News, formerly the Age of Empires blog?  We cannot currently comment on blog posts.

Also, is there any particular reason why the forums are wider than the rest of the website?  I would vote for the forum width to be the same (narrower) width as the website.

 

At the bottom of the main page there is the "Age of Empires Forum" paragraph (see picture). There is a "Join Our Community" button. When you click it, you are redirected to the main page again.

Link goes to: www.ageofempires.com

Link should go to: forums.ageofempires.com

CNS9PNQ.jpg

Something else, this is for the forum: at the bottom of the forum pages there is the Microsoft Studios logo. On the PC the proportions of the logo are wrong, stretched in height. This is OK using the phone. Also the logo is OK on the main page on PC. You know, logo Guidelines and so on ... 

Top shows forum, bottom shows main page.

UmqFSKK.jpg

 

 

 

I have viewed the www.ageofempires.com homepage using the latest versions of Edge and Chrome on my Windows 10 PC without being signed in and could not get the page to look like your screenshot.  What device and web browser are you using?

Share this post


Link to post
Share on other sites

I have viewed the www.ageofempires.com homepage using the latest versions of Edge and Chrome on my Windows 10 PC without being signed in and could not get the page to look like your screenshot.  What device and web browser are you using?

Ahhhh, it's gone, luckily I still had the tab open in Firefox so here is the screenshot as proof that I did not only imagine this:

EIMqNrJ.jpg

It was where now is the featured post.

And the Microsoft Studios logo problem is only at the forum, not at the main page, tested with IE11 and Firefox latest on Win8.1.

 

Share this post


Link to post
Share on other sites

When I click on notifications or messages, the webpage doesn't load properly.

 

But if I wait for entire page to finish loading and then if I click on notifications or messages, it works.

 

I wish you guys speedup the forum. The forum is slower than usual. It's simply slower.

Share this post


Link to post
Share on other sites

When I click on notifications or messages, the webpage doesn't load properly.

 

But if I wait for entire page to finish loading and then if I click on notifications or messages, it works.

 

I wish you guys speedup the forum. The forum is slower than usual. It's simply slower.

+1 On website speed and the notification issue

Share this post


Link to post
Share on other sites

  • Forum Statistics

    • Total Topics
      24236
    • Total Posts
      244599